jtool: v1.0 no longer disassembling decoded kernel caches

Used for discussing the various tools in the book as well as encouraging members to share tools

jtool: v1.0 no longer disassembling decoded kernel caches

Postby cartmon » Wed Mar 07, 2018 10:30 am


In jtool v(Almost Last 1 before 1.0!) (Paris II) (compiled on Dec 20 2017 20:15:00) I can disassemble a decoded kernel cache like so:

Code: Select all
jtool -d kernelcache.release.iphone9.dec

However, attempting the same invocation with jtool v1.0 (compiled on Feb 4 2018 11:44:31) results in the following error message:

Code: Select all
Can't disassemble a shared cache. Use ":" to specify a file inside the cache

I have tried using ":" to target individual kexts, but that gives the same error message and I liked being able to disassemble the whole cache.

Sorry if I'm missing something obvious and thank you for writing jtool!
Posts: 1
Joined: Wed Mar 07, 2018 10:06 am

Re: jtool: v1.0 no longer disassembling decoded kernel cache

Postby dsimerly2003 » Thu Mar 15, 2018 4:51 pm

Same issue here.
Extracted kext using joker and I get the same error.
Thinks its a shared cache for some reason.
Also, I'm using a newer version: compiled on Feb 4 2018 18:07:27.
Posts: 3
Joined: Fri Dec 29, 2017 4:01 pm

Return to Tools

Who is online

Users browsing this forum: No registered users and 3 guests